Issue with login into user account
Incident Report for Geedesk
Resolved
This incident has been resolved.
Posted Apr 30, 2024 - 04:45 UTC
Update
We are continuing to investigate this issue.
Posted Apr 30, 2024 - 04:38 UTC
Investigating
We are currently investigating this issue.
Posted Apr 30, 2024 - 04:37 UTC
This incident affected: Website.