We are facing an issue with AutoAssign and Escalation

Incident Report for Geedesk

Resolved

The issue has been successfully resolved.
Posted Mar 14, 2026 - 05:57 UTC

Monitoring

We have implemented a fix for the same and are currently monitoring the issue.
Posted Mar 14, 2026 - 05:44 UTC

Update

We have identified the issue and are fixing it.
Posted Mar 14, 2026 - 05:39 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 14, 2026 - 05:38 UTC
This incident affected: Web Application and Geedesk API.