Issue with email service provider
Incident Report for Geedesk
Resolved
This issue has been fixed by our email service provider.
Posted Nov 02, 2023 - 19:58 UTC
Identified
We have identified an issue with our email service provider. They are working to fix the same. During this period emails from Geedesk will not work.
Posted Nov 02, 2023 - 07:18 UTC
This incident affected: Web Application and Geedesk API.