Application Down

Incident Report for Geedesk

Resolved

The Issue has been resolved.
Posted May 21, 2026 - 15:34 UTC

Monitoring

The Issue is under Monitoring
Posted May 21, 2026 - 14:09 UTC
This incident affected: Web Application.