Issue with login into user account
Incident Report for Geedesk
Update
We are continuing to investigate this issue.
Posted Apr 10, 2024 - 11:22 UTC
Investigating
We are currently investigating this issue.
Posted Apr 10, 2024 - 11:21 UTC
This incident affects: Web Application.